www.ctrt.net > struts2 升级遇到的问题

struts2 升级遇到的问题

你是不是用到了Struts2的json插件?我搜到的一些可能的错误,给你参考: 大概是说那个json 插件的jar需要跟你的struts core的版本按照其官方文档说明上来用,否则就有可能报错。 下面是网上的一些资料: 当项目启动时报如下错误时:com.opensymp...

ClassNotFound, 应该是少了jar包,你看看项目里有没有commons-logging-xxxx.jar,没有就上网找一个

包冲突 只留下一个就行了 留下高版本的吧 错误指向的是xwork包,记得升级xwork包啊 楼主没问题的话 望采纳...。。........。。。。。。。。。。。

看看web.xml中配置的 Dispatcher对不对,路径可能不对。 自己点开核心jar,看看能不能找到。

依赖没有全更换成合适的 ~ ~ ~

这个问题很简单!这种问题肯定是你的Action的请求路径有问题,或者你那边没有配置好,不会因为你升级了一个版本就导致Action请求不到,仔细查看配置的路径,或者查查2.3版本的请求路径有什么特殊的配置要求,不用纠结,这种问题没什么好分析的,...

Caused by: java.util.zip.ZipException: invalid entry size 可能是下载的包损坏了,重新下载一个新的试试

起的那么早啊??!!!web.xml里面的struts2的监听换下就好了

开发项目使用的jdk版本和项目运行服务器jdk版本不同就会出现上面的问题。 修改项目java compiler的方法:在项目点右键->Perperties->Java Compiler, 修改JDK Compliance版本

1、应该是架包的问题,看下有没有架包冲突,你们用最新的Struts有意思吗? 2、你知道最新的stutrs有什么新功能或有哪些改进吗? 3、不知道就不要去升级,没必要!

网站地图

All rights reserved Powered by www.ctrt.net

copyright ©right 2010-2021。
www.ctrt.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com